当前位置:网站首页 > 服务器 > 正文

asciidoc python版本错误

adminadmin 2019-06-26 46 0


  File "/usr/bin/asciidoc", line 95

    except KeyError, k: return None

                   ^

SyntaxError: invalid syntax

make[2]: *** [shadowsocks-libev.xml] Error 1

make[2]: Leaving directory `/usr/local/src/shadowsocks-libev/doc'

make[1]: *** [all-recursive] Error 1

make[1]: Leaving directory `/usr/local/src/shadowsocks-libev'

make: *** [all] Error 2

 

这个问题是python版本变了 得需要系统安装的python版本

更改/usr/bin/asciidoc.py文件python环境    

 

将第一行注的

#!/usr/bin/env python

改为(这个2.6是之前升级python备份的老版本,根据自己备份的填写)

#!/usr/bin/python2.6



标签:asciidoc

  • 流泪

    0

  • 打酱油

    0

  • 开心

    0

  • 鼓掌

    0

  • 恐怖

    0

本文暂时没有评论,来添加一个吧(●'◡'●)

欢迎 发表评论:

请填写验证码
搜索
最近发表
标签列表
最新留言
    • 订阅本站的 RSS 2.0 新闻聚合